Spigot導入時エラー(IllegalArgumentException)

Spigot導入時エラー発生したので記録

実行環境

Windows 10
Java 10

実行コマンド

java -jar BuildTools.jar --rev 1.12

Javaエラー

Final mapped work\mapped***.jar does not exist, creating!
Exception in thread mainjava.lang.IllegalArgumentException

思い当たる節はJavaのバージョンが10ということです。

ので既にインストールしてあったJava8に変更してみます。

Java変更チェック

java -version
java version "1.8.0_112"

再実行

Success! Everything compiled successfully. Copying final .jar files now.

https://hub.spigotmc.org/jira/si/jira.issueviews:issue-html/BUILDTOOLS-324/BUILDTOOLS-324.html

1年前の情報ですが、この時はJava9でASMサポートが…みたいでした。

以上です。

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です